Page 3 of 6 FirstFirst 12345 ... LastLast
Results 21 to 30 of 53

Thread: Fuel Pump Part# EJ20G Impreza WRX

  1. #21

    User Info Menu

    Default

    How long it takes depend on how stuck on your hoses are to the sending unit m first one went really easy my last one really sucked.

    Make sure you get a real Walboro 255 not a knock off they do fail and will kill your engine in a turbo car. Another good option for some one looking to go big with there car would be to put in the new Aeromotive 340LPH its about $40 more then a Walboro 255LPH but it a really killer pump they just came out. They are the same size as the Walboro 255 sure 340LPH is a little over kill for most of us but its a baller part.

  2. #22

    User Info Menu

    Default

    Do any of you guys find issues with fuel starvation around 1/2 tank or slightly under?

    I have a DW300 pump, with a Walbro install kit (filter bag, hose, & wire), and if I corner hard around 1/2 tank, the pump loses prime and won't restart unless I top it up with gas... (ie. 'ran out of gas').

    I think the not-starting is due to the type of pump (I'm likely going to swap it out for a Walbro), but I am still trying to figure out how to avoid starving the pump??

  3. #23

    User Info Menu

    Default

    I've only had that issue when around a quarter of a tank or less. But it doesn't shut off it just jerks. So I just make sure I'm above half before I corner real hard.
    93 GC8A 5spd Graphite Gray Pearl! (SOLD)
    04 SG5 Manual Forester XT
    97 JZX100 5spd Toyota Chaser Tourer V!

  4. #24

    User Info Menu

    Default

    Are you on the stock pump & filter bag still? I think the stock filter bag hangs a bit lower than the one in the walbro kit so I'm hoping it picks up a little lower in the tank.

  5. #25

    User Info Menu

    Default

    All GC8s get that issue at the track they all have fuel slosh just under half a tank I always bring a jerry can to keep them full.

  6. #26

    User Info Menu

    Default

    I'm on the walbro 255lph with the stock fuel bag instead of the walbro one.
    93 GC8A 5spd Graphite Gray Pearl! (SOLD)
    04 SG5 Manual Forester XT
    97 JZX100 5spd Toyota Chaser Tourer V!

  7. #27

    User Info Menu

    Default

    Doesnt matter what fuel bag you use its the tank design thats the problem.

  8. #28

    User Info Menu

    Default

    Hmmm OK. I know it's the tank that's the issue, I am thinking though that the original filterbag might let it get a little more out of it than 1/2 tank.

    My major beef is that this pump can't seem to regain prime until you add more gas... (ie. need a jerry can in the car at all times).

    I've recreated this on the street twice too while cornering moderately, so it's really annoying. I'm really tempted to take out the DW pump and put in a Walbro if that means that it just just hiccups a bit but can still run without needing to fill up with gas.

  9. #29

    User Info Menu

    Default

    This thread came at at the perfect time. I was looking to upgrade the feed system.

    Can any of you Walbro owners confirm where the pump is manufactured? I know there are quite a few Chinese copies floating around the market that may self-destruct. How to tell apart the genuine ones?
    1995 STi Version II

  10. #30

    User Info Menu

    Default

    I always buy mine from a legit shop and stay away from the e-bay ones. There are many fakes out there.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •