Page 2 of 2 FirstFirst 12
Results 11 to 11 of 11

Thread: Oxygen O2 Sensor Part# for EJ20K Version III WRX/STi

  1. #11

    User Info Menu

    Lightbulb

    Thought I might as well show how I installed this 4-wire O2 sensor in an application that normally utilizes a 3-wire sensor.

    There are two white wires on the sensor for the heater, and the black wire is for the signal to the ECU. I left those three wires attached to the plug, which I might add is the correct plug for this car. I snipped the gray wire off at the plug, and attached a spade plug to it. This was then plugged into a connector on a single wire that I had grounded at the same bolt on the motor that the wiring harness from the ECU is grounded. From what I understand, for the most precise O2 sensor performance, a 4-wire O2 sensor should be grounded exactly where the ECU is grounded.

    The curved blue line shows the path of the O2 wires (which are longer than the original O2 sensor wires) to the connector of the ECU wiring harness. The red arrow shows where the gray wire spade plug location is. And the green arrow shows where the O2 sensor/ECU wiring harness is grounded.




    I currently have some other engine issues, but the O2 sensor installation seems to be working fine. In theory, a 4-wire sensor is supposed to be the best configuration (due to the superior grounding), but we'll see.

    For anyone who might be interested, here's a bit of information about the O2 sensor. I'm not sure of the brand (see previous post)... but it's made in Japan and has two sets of numbers on it... 1337 and either OC29 or 0C29. I can't tell if that first figure is a capital "o" or if it's a zero.
    Last edited by Vancouver98STi; 04-04-2018 at 05:45 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •