Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: The Cresta/Chaser/Mark II Audio discussion thread

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1

    User Info Menu

    Default The Cresta/Chaser/Mark II Audio discussion thread

    I picked up a deck on boxing day, and installed it today. I read online with some confusion as to what harness to employ in this task, so I just picked one and ordered it on ebay. Turned out it was the right one.
    METRA 70-8112 TURBOWIRE for Toyota/Lexus 92-99 amplifier integration
    this one has 4 RCA Plugs and then the regular wires.
    It doesn't appear to line up to the stock harness to allow for power antenna, so if you have one (I don't know if this is a feature on any of these cars) then you have been warned!

    My X105 has the subwoofer in the rear deck, and I presume the amplifier ! HaHa!

    Removing the stereo cover is pretty easy, first you need to remove the base around the shifter (mine is an auto). Pry gently near the armrest, and it should pop off the clips. Then pick a spot on the stereo surrround and gently pry, then work your way around. Once you are in, remove the two harnesses in the surround for the cigarette lighter, and the trim is gone.
    remove 4 hex bolts (likely 8/10mm or so, I can't remember) and the whole assembly will come out. Then do your business!

    One note, there seemed to be an extra antennae plug that was a tad smaller than what I'm used to seeing. I'm not sure what it is, so I tried my deck before reinstalling to confirm am/fm operation and it worked great, so I taped it up with electrical tape, and tucked it away.

    As for audio, the overall sound is quite good in my Cresta, so I won't be changing or adding anything there. I'm pleased.
    I'm curious to see what others will do here though, so post away!

  2. #2

    User Info Menu

    Default

    Here's a link of pictures on how to remove the deck in a JZX100 which I assume is really close to a JZX105.

    https://plus.google.com/photos/11652...914?banner=pwa

    I'm in the same boat as you with the sound quality these cars have from factory, I have no intention of upgrading my audio system in the Chaser, I love the stock deck even. As long as I've got my satellite radio hardwired in I'm happy
    93 GC8A 5spd Graphite Gray Pearl! (SOLD)
    04 SG5 Manual Forester XT
    97 JZX100 5spd Toyota Chaser Tourer V!

  3. #3

    User Info Menu

    Default

    yup. that's exactly it. good slide show Simeon Taylor, whoever you are!
    The main reason for swapping mine out was that the stock deck would cut out to about 90% audio, and 10% static, no matter what source, every once and a while. The sound is much better with this new deck though, even though the stock setup is quite good.

  4. #4

    User Info Menu

    Default

    Oh that's strange. I haven't experienced anything like that at all with my Chasers system.
    93 GC8A 5spd Graphite Gray Pearl! (SOLD)
    04 SG5 Manual Forester XT
    97 JZX100 5spd Toyota Chaser Tourer V!

  5. #5

    User Info Menu

    Default

    Yeah, I have never seen that with a system before, I think mine was just going. I tossed it of course. Now I am going to have to find another way to play my fine young cannibals tapes !

  6. #6

    User Info Menu

    Default

    I've bought online new deck as well for Mark II - JVC KD-R80BT, haven't received it yet.
    Can you guys recommend 1 DIN cover plate (which one and where I can buy it?): stock deck is 2 DIN and new one is 1 DIN, so I need something to cover the hole.

  7. #7

    User Info Menu

    Default

    I used a toyota pocket. I believe I picked it up at future shop/best buy or certified radio. I can't remember, cause it was a couple years back. Any shop should have it though.. bout 10-20 bucks

  8. #8

    User Info Menu

    Default

    Bought from eBay [Metra 88-00-9000 Dash Kit] to cover the hole and Metra 70-1761 harness to connect new JVC deck. Hopefully it will fit.



  9. #9

    User Info Menu

    Default

    Pretty sure the harness is wrong. Looks like a jzx90 harness, but keep us updated. I think that you do not have the amp and sub kit right?

  10. #10

    User Info Menu

    Default

    Quote Originally Posted by Soren View Post
    Pretty sure the harness is wrong. Looks like a jzx90 harness, but keep us updated. I think that you do not have the amp and sub kit right?
    No, I don't have stock amp.
    I didn't pull out my stock deck yet but it looks exactly the same as here: Toyota 86120-2A300
    Made by Pioneer (model: FH-M8166ZT), back sockets looks like harness I ordered, will see if it will fit

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •