Results 1 to 2 of 2

Thread: 2003 Subaru Legacy GT Spec B Climate Control Relay Broken / Low Voltage

  1. #1

    User Info Menu

    Default 2003 Subaru Legacy GT Spec B Climate Control Relay Broken / Low Voltage

    OK guys so I mentioned in this thread what I think happened.

    https://forums.jdmvip.com/threads/91...7844#post97844

    Basically I was trying to take the 12V ignition voltage from the "R. Def Relay" and I ran it to my headlamp relay trigger. It worked fine for the first light.
    Then I ran a second wire to the second headlight relay and the headlights stopped working. I assumed I burned out the headlight relay fuse again but they were fine.

    Then I checked the "R. Def Relay" fuse and it was fine too. The problem is that the pin on the relay terminal should get 12V with ignition but after drawing too much power for the headlights last night it only gets like 1V. I'm not sure what is causing this or maybe there's another related fuse I'm not aware of.

    I would be very appreciative if anyone could help me out with this!

    in car fusebox diagram here:


    picture of relays in engine bay here:

  2. #2

    User Info Menu

    Default

    OK guys so I solved it! It was the 15A "A / C IG" fuse that was blown (3rd column, second last row). Climate control is now alive and well now that it was replaced.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •